Aktivlenkung elektrische Verrieglung.

  • Aktivlenkung elektrische Verrieglung.

    Hi, habe heute ein gebrauchtes lenkgetriebe eingebaut da meins spiel hatte.
    Soweit so gut.
    Nur wirft er den Fehler elektrische verrieglung. Kann es auch nicht initialisieren, das Prog bricht schon beim rotarwinkel zurücksetzen ab.
    Wo könnte der Fehler liegen??
  • Mal ein Gedanke von mir. Die aktivlenkung hat ja eine elektrische Sicherheitssperre. Im fs steht elektrische Verrieglung und das sie im werkstattmodus ist. Sie lässt sich nicht initialisieren da sie bei der rotarwinkel zurücksetzen meldet geht nicht. Ich denk mal so, wenn das sperrventil hängt oder nicht angesteuert wird, kann sich das Teil ja nicht bewegen und kann deswegen nicht zurückgesetzt werden. Die sicherheitssperre könnte man aus dem defekten ja übernehmen.
    Hatte das schon einer bzw. ist das so unlogisch gedacht?
  • Wenn dieses STG im Werkstattmodus ist, muss es bestimmt erst daraus wieder zurückgeholt werden.
    Sicher´lich wird im Werkstattmodus nicht verriegelt, damit das FZG besser bewegt werden kann etcpp.

    Wird wohl ähnlich wie bei der elektrischen Bremse sein, die wo im Werkstattmodus gefahren sein muss, damit man daran gefahrlos arbeiten kann.
  • Und wie bekommt man das Teil da raus. Initialisieren, aktivieren geht ja nicht.
    Ich habe ja die Hoffnung das dies alles nur am sperrventil liegt. Quasi wenn es defekt ist und das ganze gesperrt ist, kann man das ganze ja nicht aktivieren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Madmax71 ()

  • Ich glaub das ich den Fehler gefunden habe.
    Konnte sie mit i..a aus dem werkstattmodus holen. Wahrscheinlich hab ich sie damit auch reingesetzt. Und die aktivierungsroutine durchführen. Ging auch bis zum Ende durch da sagte Reihng. Initialisiert und es machte Ping Aktivlenkung defekt. Fs ausgelesen elektrisches sperrventil stand bei i..a bei rg wieder elektrische Sperre. Da wir alle elektrischen Bauteile des alten Getriebes ausgebaut hatten, weiß ich das das Teil ein elektrisches sperrventil hat. Sieht von außen fast so aus wie der servotronikwandler.
    Werde die Tage das Ventil mal wechseln, in der Hoffnung das es dann geht.
  • So hab die Lenkung am laufen. Wer den Prüfplan von rg einfach mal befolgt ist klar im Vorteil.
    Nachdem das sperrventil gewechselt wurde und es immer noch nicht ging.
    Bin ich mal strickt nach prüfplan vorgegangen.
    Also Steuergerät freigelegt und den wiederstand gemessen. War null.
    Dann hab ich das andere sperrventil direkt am Steuergerät angeschlossen und siehe da, die Lenkung lies sich initialisieren. Also konnte es nur ein Problem mit der Verkabelung sein. Da ich keine Lust hatte, den Orig. Kabelbaum zu prüfen, das kommt dem lenkgetriebewechsel gleich, sprich Va. absenken, hab ich 2 neue Kabel verlegt und das sperrventil mit dem Steuergerät verbunden. Und es funktioniert. Ich frag mich ehrlich was das sperrventil für eine Funktion hat, aber egal. Hätte auch einen 20 Ohm widerstand dazwischen klemmen können, nur da geht das sperrventil ja nicht mehr.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Madmax71 ()

  • Madmax71 schrieb:


    Hätte auch einen 20 Ohm widerstand dazwischen klemmen können, nur da geht das sperrventil ja nicht mehr.
    Hat jemand die PIN-Belegung vom Aktivlenkung-Steuergerät, damit ich mit einen Widerstand testen kann ?

    Bei meinem nun auch "Aktivlenkung defekt" mit Fehlerspeichereintrag " elektrischer Sperrenfehler".
    Wahrscheinlich auch defekte Stromversorgung zum Sperrenventil...
  • Gegenwind schrieb:

    Hat jemand die PIN-Belegung vom Aktivlenkung-Steuergerät, damit ich mit einen Widerstand testen kann ?
    Dateien

    Dieser Beitrag wurde bereits 8 mal editiert, zuletzt von Ben-G () aus folgendem Grund: Blöde Tabelle wird nicht angezeigt :/ Jetzt als Anhang

  • @Ben...herzlichen Dank! Dann ist es PIN 21 und 22.

    @Madmax...danke auch dir!
    Welchen Widerstand könnte man da testen ? Du meintest 20 Ohm. Und was wäre die Wattzahl ungefähr ?

    Eigentlich wäre es mir ganz recht, das Sperrventil deaktiviert zu lassen, dann klackt es beim Motorabstellen
    wenigstens nicht mehr so penetrant. Ab MJ 08 gibt`s das Ding ja auch nicht mehr...
    Mir kommt es eigentlich nur darauf an, den Fehler in "I**A" löschen zu können:
    111.jpg
  • Neu

    Nachdem zwischenzeitlich eine Wunderheilung geschehen war und die Aktivlenkung ohne Fehler lief,
    ist der Fehler "elektrischer Sperrenfehler" plötzlich und dauerhaft wieder da.
    Habe dann testweise wie "madmax" schrieb einen Widerstand in die Zuleitung zum Sperrventil gesetzt.

    Die Servounterstützung der Lenkung funktioniert mit dem Widerstand, jedoch wird das Aktivlenkung-Steuergerät über 80 Grad heiß im Betrieb.
    Ich frage mich sowieso, warum liegt da Dauerspannung an ? Um den Stift von der Sperre während dem Motorlauf rauszuziehen ?
    Wenn nach Abstellung des Motors der Stift wieder rauskommt um irgendwas zu sperren, wieso kann die Lenkung bei
    "Sperrenfehler" (dann ohne Servounterstützung) dennoch betrieben werden ??
    Der Stift wird ja bei Defekt nicht wieder magnetisch reingezogen und bleibt draußen um wie gesagt was zu sperren...

    Bild ausm Netz:
    Dateien
    • 2.jpg

      (25,39 kB, 5 mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Gegenwind ()

  • Neu

    Der Stellmotor des Überlagerungsgetriebes wird durch eine Stellmotorsperre arretiert, die das Schneckengetriebe des Überlagerungsgetriebes blockiert.
    Die Stellmotorsperre ist über eine Feder vorgespannt und wird über die Spannungsversorgung entgegen der Vorspannung gehalten. Eine Unterbrechung der Spannungsversorgung führt somit zur Blockierung des Schneckengetriebes.
    Das arretierte Überlagerungsgetriebe stellt sicher, dass ein fahrerseitiges Lenken über die Lenksäule weiterhin möglich ist. Die Lenkung reagiert dann wie eine konventionelle Lenkung, allerdings bei direkter Lenkgetriebeübersetzung.
    Die rein mechanische Übersetzung zwischen Lenkrad und Vorderrädern bleibt immer erhalten, auch bei Ausfall der Aktivlenkung.

    Die Stellmotorsperre blockiert den Stellmotor:
    • im Fehlerfall
    • bei Fahrzeugstillstand
    Die Stellmotorsperre entriegelt ab einer Versorgungsspannung von ca. 3,2 Volt.



    Gegenwind schrieb:

    Habe dann testweise wie "madmax" schrieb einen Widerstand in die Zuleitung zum Sperrventil gesetzt.
    Was soll der Sinn des Widerstandes sein?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ben-G ()

  • Neu

    Danke dir Ben für die ausführliche Erklärung.
    Frage mich jetzt nur, warum die Aktivservo trotz nicht gezogener Sperre (da keine Spannung) während der Zwischenschaltung
    des Widerstands funktioniert ?? Zwar mit schief stehendem Lenkrad und einem neuen Fehler "Motorblockade" (Abb,unten).
    Aber eigentlich dürfte die Aktivservo ja gar nicht gehen bei weiterhin Stellmotor-Blockade...

    Problem aber bei der ganzen Sache: Die Stellmotorsperre gibt es NICHT im ETK ! Wo bekomme ich das her ?
    Sonst würde ich hier keine Romane schreiben und hätte das Ding längst getauscht.

    Aber die Funktion des Stellmotorsperre ja zwingend notwendig, um den Fehler "Motorblockade" löschen zu können.
    Einfach den Blockade-Stift von dem Ding abschleifen ? Dann wäre die Blockade des Stellmotors ja aufgehoben...
    Dateien
    • Fehler.jpg

      (46,2 kB, 5 mal heruntergeladen, zuletzt: )
    • 2.jpg

      (25,62 kB, 4 mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 7 mal editiert, zuletzt von Gegenwind ()

  • Neu

    Eventuell klemmt die Sperre mechanisch ja gar nicht im Stellmotor.

    Die einzige Möglichkeit, wie das SG ein Klemmen erkennen kann, ist ja über den aufgenommen Strom vom Magnetschalter der Sperre. Eine weitere Rückführung über die Position der Sperre gibt es ja nicht.
    Möglich dass der Stift der Stellmotorsperre auch im eingefahrenen oder nur halb ausgefahrenem Zustand klemmt, sodass der Motor mechanisch gar nicht blockiert ist.

    Sicher dass der Stellmotor vom Überlagerungsgetriebe fährt wenn der Wiederstand am SG angeschlossen ist? Also dass die Aktivlenkung aktiv ist mit dem Wiederstand?


    Bau doch die Sperre mal aus, ist ja kein Hexenwerk, und schau sie dir mal an. Unter Umständen ist sie nur schwergängig und funktioniert eben ab und zu mal und manchmal eben nicht...

    Ich weiß nicht, ob das Abschleifen vom Pin wirklich so gut ist. Theoretisch wird es funktionieren, du verlierst halt eine Sicherheitsfunktion im Fehlerfall. dann kann unter Umständen genau das passieren was du schon hast, nämlich dass das Lenkrad schief steht. Wenn man das weiß, ist das eher nicht so das Problem, wenn dir das aber während der Fahrt passiert....
    Weiterhin kann sein, dass das AL-SG die Position vom Stellmotor verliert nach dem Abstellen, da das Überlagerungsgetriebe ja nicht blockiert ist und nach dem Abstellen durch Bewegungen am Lenkrad seine Position noch ändern kann.

    Also, Sperre ausbauen, begutachten und dann weiter schauen...